Gecko Cloud Disruption Due to Upstream Cloud Provider Outage

Incident Report for Gecko Cloud

Monitoring

GeckoC loud is back to normal operation as of 9:50 AM EST.

Our technical team continues to monitor the platform closely and is investigating the root cause.

Thank you for your patience.
Posted Jun 12, 2026 - 12:12 EDT

Investigating

Service disruption on Gecko Cloud
Since 9:15 AM EST, we have been experiencing an issue linked to a broader outage impacting multiple cloud providers.

Some Gecko Cloud services are affected, and you may notice slow loading times or temporary errors in the app and connected features.

Our team is actively investigating and will post updates here as we learn more.
Posted Jun 12, 2026 - 09:48 EDT
This incident affects: Android App, iOS App and Cloud Services (Waterlab Recommandations, Authentication, End-user App API).